Cocoapods (privados) no pueden encontrar la especificación

Tenemos cocoapods privados. Cuando pod repo :

 company-private - Type: git (origin) - URL: ssh://[email protected]//path/git/PrivateCocoapods - Path: /Users/Username/.cocoapods/repos/company-private master - Type: git (origin) - URL: https://github.com/CocoaPods/Specs.git - Path: /Users/Username/.cocoapods/repos/master 

~/.cocoapods/repos :

 $ ls company-private master $ cd company-private $ ls Specs $ cd Specs: $ ls MyProject $ cd MyProject: $ ls 0.0.19 0.0.2 0.0.5 $ cd /0.0.5: $ ls MyProject.podspec 

En otro proyecto .podfile estoy tratando de:

 pod 'MyProject', '0.0.5' 

Y después de la pod install o la pod update , recibo:

 $ pod install Analyzing dependencies [!] Unable to find a specification for `MyProject (= 0.0.5)` 

¿Alguien tiene alguna idea de por qué no funciona …?

— editar —

Puedo reproducirlo en cualquier computadora simplemente escribiendo la pod install . No estaba funcionando así previamente. He utilizado pod repo push company-private MyProject.podspec para enviar al server. Estuvo funcionando hace una semana. Hoy he empujado una nueva versión de la misma manera, pero con --allow-warnings flag. Cuando intenté 0.0.19 a la versión 0.0.19 , no estaba funcionando. He clonado el repository y agregado la carpeta Spec mientras tanto (para que pueda verlo ahora en ls ), pero todavía no está funcionando.

– edit2 –

Salida de verboso:

 $ pod install --verbose Preparing Analyzing dependencies Updating spec repositories $ /usr/local/bin/git rev-parse >/dev/null 2>&1 $ /usr/local/bin/git rev-parse >/dev/null 2>&1 Updating spec repo `master` $ /usr/local/bin/git pull --ff-only From https://github.com/CocoaPods/Specs 4715d39..f21e61b master -> origin/master Updating 4715d39..f21e61b Fast-forward Specs/ISO8601-re2c/0.3.1/ISO8601-re2c.podspec.json | 24 ++++++ Specs/Mobily/2.0.77/Mobily.podspec.json | 91 ++++++++++++++++++++++ Specs/NJISO8601/0.2.2/NJISO8601.podspec.json | 22 ++++++ 3 files changed, 137 insertions(+) create mode 100644 Specs/ISO8601-re2c/0.3.1/ISO8601-re2c.podspec.json create mode 100644 Specs/Mobily/2.0.77/Mobily.podspec.json create mode 100644 Specs/NJISO8601/0.2.2/NJISO8601.podspec.json Inspecting targets to integrate Using `ARCHS` setting to build architectures of target `Pods`: (``) Finding Podfile changes - MyProject Resolving dependencies of `Podfile` Finished resolution (0 steps) (Took 0.006555 seconds) (2015-03-13 15:06:41 +0100) [!] Unable to find a specification for `MyProject (= 0.0.5)` 

Cocoapods versión 0.36.0 requiere que especifiques explícitamente el repository fuente en tu file Pod, por ejemplo:

 source 'https://github.com/CocoaPods/Specs.git'