CruiseControl.NET – Nota no utilizada – <trunkURL>?

Estoy empezando con CruiseControl .NET (utilizando el libro de continuous integration de Manning que acaba de salir) y estoy teniendo un problema con el file de configuration.

Recibo el error: "nodo no utilizado" en la label <trunkURL> .

El file de configuration (ligeramente limpiado, usando [] como marcadores de position) está debajo. ¿Alguien puede detectar mi error? Estoy pensando / esperando que sea algo simple.

 <cruisecontrol xmlns:cb="urn:ccnet.config.builder"> <!-- This is your CruiseControl.NET Server Configuration file. Add your projects below! --> <project name="Build[Project]Lib"> <workingDirectory>F:\CI\Build[Project]Lib\</workingDirectory> <artifactDirectory>F:\CI\Artifacts.Build[Project]Lib</artifactDirectory> <webURL>http://localhost/ccnet</webURL> <triggers> <intervalTrigger initialSeconds="0" /> </triggers> <sourcecontrol type="svn"> <executable>C:\Program Files\CollabNet\Svn\svn.exe</executable> <trunkURL>https://localhost:443/svn/[Solution]/trunk/src/[Project].Lib/</trunkURL> <username>buildmaster</username> <password>[Password]</password> </sourcecontrol> <tasks> <msbuild> <executable>C:\Windows\Microsoft.NET\Framework\v4.0.30319\msbuild.exe</executable> <projectFile>[Project].Lib.csproj</projectFile> <buildArgs> /p:Configuration=Release /verbosity:minimal </buildArgs> <logger>F:\CruiseControl.NET\server\ThoughtWorks.CruiseControl.MSBuild.dll</logger> </msbuild> </tasks> </project> 

¡Gracias de antemano por cualquier ayuda que puedas aportar!

Todo lo mejor, Sean

De hecho, encontré la respuesta después de un poco más de búsqueda (¡por supuesto, justo después de publicar!)

En cualquier caso, para reference futura, el problema era que estaba usando <TrunkURL> cuando debería haber estado usando <TrunkUrl> .