Despliegue de capistrano cap: la installation no crea ningún file

No recibo ningún post de error mientras ejecuto cap deploy:setup . Intenta crear una carpeta /myapp como mkdir -p /home/user/apps/myapp , y también otras carpetas (releases, compartidos). No hay ningún problema de permiso ya que puedo ejecutar mkdir -p /home/user/apps/myapp sin ningún error en el terminal. Además, la cap deploy:check da la You appear to have all necessary dependencies installed . ¿Se supone que tengo esas carpetas creadas con la cap deploy:setup ? Si es así, ¿por qué no recibo ningún post de error y también las carpetas creadas?

Aquí está mi file config / deploy.rb:

 set :application, "myapp" set :location, "myserver" set :domain, "apps.mydomain.com" set :user, "app_admin" set :repository, "svn+ssh://[email protected]/home/svn/myapp" set :svn_username, "svn_admin" set :svn_password, "password" set :use_sudo, false set :scm, :subversion default_run_options[:pty] = true role :web, location role :app, location role :db, location, :primary => true set :deploy_to, "/home/app_admin/#{application}" set :deploy_via, :checkout ssh_options[:forward_agent] = true namespace :deploy do task :start, :roles => :app do run "touch #{current_path}/tmp/restart.txt" end task :stop, :roles => :app do #do nothing end desc "Restart Application" task :restart, :roles => :app do run "touch #{current_path}/tmp/restart.txt" end end 

¿Qué versión de capistrano? ¿Qué sistema operativo? Tengo problemas con Capistrano en Ubuntu: ¡testing Windows! Por lo general, he descubierto que Windows es la mejor plataforma de server. Excepto por los choques poco frecuentes, el server de Windows es muy poderoso.