el command de installation del puerto se congela al instalar subversión a través de MacPorts

Tengo problemas para instalar subversion a través de MacPorts. La salida del command desde el port es:

 # port install subversion ---> Computing dependencies for subversion ---> Configuring subversion 

En este punto, se sienta allí indefinidamente. I Ctrl + C'd fuera de eso, y ejecuté el puerto con la opción -d para get información de debugging, esto es lo que obtengo:

Pastebin que contiene salida de command

Entonces, en este punto, puedo ver que se está atascando en el script de configure al final de las comprobaciones de Python o al comienzo de la próxima comprobación.

El script de configure en este caso se encuentra en /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_subversion/subversion/work/subversion-1.7.7

configure calls un script auxiliar ( $abs_srcdir/build/find_python.sh ) que devuelve python , el script configure realiza algunas comprobaciones y devuelve la ruta completa al ejecutable de python , y pasa a la siguiente comprobación. La siguiente comprobación, según la línea 20129 de configure , es para una JVM (que sí tengo instalada). Sin iterar manualmente a través del script de configuration, pensé en consultar aquí y ver si había algún consejo de la comunidad.

 Mac OS X 10.8 (Mountain Lion) MacPorts v2.1.2 Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909) Xcode 4.5.2 (with up to date command line tools) Python 2.7.2 

Si hay alguna otra información relevante que no incluí, házmelo saber.

Pude instalar Subversion pirateando el script de configuration para simplemente configurar el OSX_VERSION en el código rígido "10.8" y ejecutar nuevamente el command de installation del puerto. Por alguna razón, está pendiente de la serie de commands:

/usr/bin/sw_vers | grep ProductVersion | cut -f2 | cut -d"." -f1,2

Creo que el segundo corte es el problema porque ejecutar ps -ef en una segunda window muestra el corte -d"." -f1,2 -d"." -f1,2 todavía en ejecución. Tal vez trate de rodear el -f1,2 con comillas?

Sin embargo, simplemente establecer OSX_VERSION="10.8" en TODAS las ubicaciones del script de configuration me permitió instalar subversion.

Suena estúpido, lo sé … ¿pero trataste de reiniciar tu sistema?

Después de actualizar OS X (y por lo tanto también Xcode), también me quedé atrapado en configure con diferentes packages (ccutils, gmp y otros). Pasé algún time buscando una respuesta, reinstalé todo, nada me ayudó.

Reiniciar fue el último recurso … y lo hice para mí: /