Instalación de la última versión de git en ubuntu

Mi versión actual de Git 1.7.9.5 …

Necesito actualizar al less a git 1.7.10 para tener el command git clone para que funcione correctamente

sudo add-apt-repository ppa:git-core/ppa para actualizar pero resultó en esto:

 Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 125, in <module> ppa_info = get_ppa_info_from_lp(user, ppa_name) File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp curl.perform() pycurl.error: (7, "couldn't connect to host") 

¿Qué se supone que debo hacer para instalar el último git (para actualizar)?

El equipo de Ubuntu git maintainers tiene un PPA solo para eso

 ppa:git-core/ppa 

Solo haz:

 sudo add-apt-repository ppa:git-core/ppa sudo apt-get update sudo apt-get install git 

Si no se encuentra el command add-apt-repository , instálelo primero con

 sudo apt-get install python-software-properties 

La pregunta era: "Qué hacer cuando el command sudo add-apt-repository ppa:git-core/ppa falla".

Tuve el mismo problema en una VM detrás de un proxy. Lo resolví con los siguientes dos pasos:

  1. Configurar variables de entorno de proxy

     export http_proxy=http://<user>:<pwd>@<proxy_url>:<port_number> export https_proxy=http://<user>:<pwd>@<proxy_url>:<port_number> 
  2. Ejecute nuevamente el command add-apt-repository como sudo con la opción -E que preserva el entorno del usuario:

     sudo -E add-apt-repository ppa:git-core/ppa