libiconv.2.dylib Tema del León de Montaña

Cada vez que trato de instalar algo dependiente de git ( homebrew por ejemplo) aparece este error:

> Incompatible library version: git requires version 8.0.0 or later, but > libiconv.2.dylib provides version 7.0.0 

He reinstalado git y xcode pero el error sigue siendo lanzado. No tengo macports instalados.

¿Alguien tiene ideas sobre cómo resolver?