Mover una aplicación de Django 1.4 a 1.8

Tenía un proyecto anterior ejecutándose en Django 1.4 y ahora estoy tratando de "revivirlo".

Específicamente, mi sistema en ese momento era OS-X y ejecutaba BITNAMI DJANGO STACK 1.4.6 (Python 2.7) . Extraje el código fuente del repository de Git en una nueva installation de BITNAMI DJANGOSTACK 1.8 https://bitnami.com/stack/django/installer#osx

Idealmente, habría actualizado todo a medida que avanzaba, pero no puedo encontrar una descarga de DJANGOSTACK 1.4.6. Para ser sincero, no sé cuál hubiera sido la mejor opción para actualizar esta aplicación.

Esto es lo que hice:

  • Código clonado de mi repository Bitbucket.
  • Como la database esperada no formaba parte de lo que había comprometido con el repository de Git. Entonces algunos datos se pierden.
  • Creo que no tengo una copy de security de la database o quizás los cambios no comprometidos con el repository de Git (más probablemente, ¿no?) Ocasionaron algunas diferencias con el esquema en algún momento y me dieron una advertencia de migration. Problema de migration: http://sprunge.us/jIXC
  • Se ejecutó la Run 'python manage.py migrate' sugerida Run 'python manage.py migrate'
  • Algunos enlaces rotos y funcionalidades se corrigieron. Los detalles están aquí: http://sprunge.us/QTJF

Mi ruptura principal es con lo que parece ser una location incorrecta para una plantilla? (Traceroute completo aquí: http://sprunge.us/hQHK )

TemplateDoesNotExist at /metrics/metrics_search_form/ metrics/metrics_search_form.html Request Method: GET Request URL: http://localhost:8000/metrics/metrics_search_form/ Django Version: 1.8.11 Exception Type: TemplateDoesNotExist Exception Value:
metrics/metrics_search_form.html Exception Location: /Applications/djangostack-1.8.11-0/apps/django/lib/python2.7/site-packages/Django-1.8.11-py2.7.egg/django/template/loader.py in get_template, line 46 Python Executable: /Applications/djangostack-1.8.11-0/python/bin/python Python Version: 2.7.11

La plantilla sale pero está en:

 /metrics/templates/metrics/metrics_search_form.html 

¿Es este un nuevo comportamiento desde Django 1.4 a Django 1.8? Si es así, ¿cómo puedo solucionarlo?

¿Debería actualizar este proyecto de otra manera?

¡Gracias!