No se puede instalar svn en STS

Intento instalar svn en mi STS pero estoy teniendo algunos problemas ya que estoy obteniendo algunos errores:

An error occurnetworking while collecting items to be installed session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,org.eclipse.team.svn.core.nl1,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.m2e.sources,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.mylyn.sources,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.nl1,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.nl1.sources,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.resource.ignore.rules.jdt.sources,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.revision.graph.sources,4.0.0.I20160226-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.sources,4.0.0.I20160604-1700 No repository found containing: osgi.bundle,org.eclipse.team.svn.ui.nl1,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.m2e.sources,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.mylyn.sources,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.nl1,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.nl1.sources,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.resource.ignore.rules.jdt.sources,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.revision.graph.sources,4.0.0.I20160226-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.source,4.0.0.I20160604-1700 No repository found containing: org.eclipse.update.feature,org.eclipse.team.svn.sources,4.0.0.I20160604-1700 

He seguido el tutorial aquí https://www.eclipse.org/subversive/videos.php pero parece que no lo está teniendo. ¿Hay algo que me estoy perdiendo? El conector aún no está instalado porque el tutorial dice que debe instalarse más tarde (pero incluso lo intenté cuando lo instalé y no me importó). Mi versión de STS es esta: Spring Tool Suite

 Version: 3.6.4.RELEASE Build Id: 201503100339 Platform: Eclipse Luna SR1 (4.4.2) 

¿Alguna idea? Gracias