problema de installation de git

Aparece un post de error cuando escribo el command make cuando estoy en el directory git actual, ¿cómo soluciono este problema?

Esto es lo que escribo y recibo:

cd git-1.7.5.4

git-1.7.5.4 $ make

~ bash: make: command no encontrado.

¿Cómo puedo aliviar este problema para poder ejecutar los commands make para git y curl?

Necesitas instalar Make. Lo más probable es que no tenga instalada la cadena de herramientas de su sistema operativo. Creo que para Mac OS X necesitas instalar XCode, pero puede haber otra manera.

Nota específica de Git: necesitas configurar tus opciones de config.mak . En particular, debe tener NO_TCLTK=YesPlease si no tiene Tcl / Tk. Algunas otras opciones pueden ser necesarias. Además, si no tiene encabezados libcurl, use NO_CURL=YesPlease (ADVERTENCIA: no podrá usar serveres http o https). Si no tiene encabezados de openssl, use NO_OPENSSL=YesPlease . Y así. Busque en Makefile para más detalles.

De acuerdo con el Makefile, ya que estás usando Darwin, necesitas

 NEEDS_CRYPTO_WITH_SSL=YesPlease NEEDS_SSL_WITH_CRYPTO=YesPlease NEEDS_LIBICONV=YesPlease 

Si planea usar el set de testings, NO_SVN_TESTS=YesPlease puede acelerar el time para hacerlo.

Considere habilitar BLK_SHA1=YesPlease si corresponde, para Mac OS X. (No estoy seguro de esto)

¿Instalaste XCode?

En una nota lateral, ¿por qué lo comstack usted mismo en lugar de utilizar los files binarys precomstackdos o la installation de un administrador de packages como Homebrew ?

¿Hay algún motivo por el que intentas crear desde la fuente en lugar de utilizar el instalador empaquetado ?